Перейти к содержанию
Форумы
admin

Обновление PHP: v7.2 с 18.10.2018

Рекомендуемые сообщения

18.10.2018 года на всех аккаунтах php будет переключен на версию 7.2.

Если Вы по каким-то причинам хотите оставить у себя php 5.6 (кодировка UTF-8) или Вам нужен php 5.5 (кодировка windows-1251), сообщите об этом в техническую поддержку, указав логин cPanel или имя домена.

Переключить Ваш сайт на php v7.2 можно заранее (уже) - для этого также напишите нам в техническую поддержку.

Сегодня нами на сервере было установлено соответствующее ПО, позволяющее переключать аккаунты на разные версии php.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Скажите пожалуйста, а связана ли с этим ошибка при попытке открыть форум у себя на сайте? Ещё буквально час или два назад всё работало.

Ошибка:

General Error

SQL ERROR [ mysql4 ]
mysql_connect function does not exist, is mysql extension installed? []
An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Полагаю, что да, связано. Скорее всего, у Вас очень старое программное обеспечение и его необходимо обновить, т.к. сейчас используется mysqli, а не mysql.

Гугл на подобную Вашу ошибку выдает например

https://area51.phpbb.com/phpBB/viewtopic.php?t=48971&start=30

 

Соответственно для начала попробуйте найти config.php или подобный файл, возможно в нем есть настройка изменения с mysql на mysqli.

Не будет что-то получаться - сообщите что именно, попробую помочь и решить проблему. Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Переключил пока что Ваш аккаунт на php 5.6 (переключиться обратно на php 7.2 Вы модете в cpanel -> multiphp manager).

Проблемой заняться надо, т.к. php 5.6 осталось недолго http://php.net/supported-versions.php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Благодарю.

Форум обновляла полтора года назад. Весия phpBB указана 3.1.10, сервер базы данных MySQL 5.6.39.

Укзано, что последняя версия phpBB 3.2.3. Это актуальная?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

×