Перейти к содержанию
Форумы
KF-WEB

Warning: date()

Рекомендуемые сообщения

number_format - перепроверьте настройки. В настройках, подразумевающих число, должно быть указано число.

date - на сервере что-то не так с временной зоной.

 

После чего начались проблемы? Максимально подробно обо всем во всех деталях.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Началось с автоматического обновления. config.php не менял. В настройках все значения числовые, за исключением номеров кошельков WM и секретных ключей.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Base Version: 1.03

По всей видимости, обновление базы данных не требуется!

 

Дополнительно Вы можете произвести проверку целостности базы данных.

Base Version: 1.03.

 

Checking database structure with /admin/modules/database.php: all it's OK!

 

Попробую поставить "с нуля"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

При новой установке Warning: number_format() пропал, осталось

Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Moscow' for 'MSK/4.0/no DST' instead in

Куда копать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

[offtop]Как SEOшник SEOшнику - серп в различных регионах отличается[/offtop]

Какой ответ на форуме фёрстов верен? Если последний, то куда засунуть

date_default_timezone_set('Europe/Moscow');

В какой файл, и каков синтаксис этого написания.

По поводу php.ini - Вы станете громко смеятся, но билинг у меня на шареде.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ответ про php.ini. Если биллинг на шареде и там запрещено использовать свой php.ini, то попробуйте также в config.php или license.php добавить второй строчкой

date_default_timezone_set('Europe/Moscow');

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добавил второй строчкой в config.php - всё заработало правильно.

Спасибо, вопрос закрыт.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


×
×
  • Создать...